Software management

Ports

  • Checkout stable ports branch

echo "FETCH_PACKAGES=yes" >> /etc/mk.conf
cd /usr
cvs -qd anoncvs@anoncvs.ca.openbsd.org:/cvs get -rOPENBSD_6_8 -P ports
  • Which packages / ports need to be updated?

/usr/ports/infrastructure/bin/out-of-date
  • Update a port

cd /usr/ports/<portname>
make update

Update base system

syspatch

Upgrade to a new release

sysupgrade
  • If you cannot or dont want to upgrade by CD / USB / PXE / sysupgrade use the Upgrade without the Install Kernel documentation

Flash support

  • Adobe and Chrome flash plugins do not work on OpenBSD

  • But you can use Gnash in Firefox

pkg_add gnash
mkdir /home/<user>/.mozilla/firefox/<account_id>.default/plugins
cd /home/<user>/.mozilla/firefox/<account_id>.default/plugins
ln -s /usr/local/lib/mozilla/plugins/libgnashplugin.so

Readmes for packages

  • Can be found in /usr/local/share/doc/pkg-readmes

Automatic installation over PXE

Building images for cloud and embedded devices